OpKey Blog

Reasons why we are not upgrading to Selenium 3.0

Radhe Shyam Prajapati 13.01.2017

 

In this OpKey Release we are still using Selenium 2.53 which is the stable version of Selenium and supported by all latest web browsers (Mozilla Firefox, Google Chrome & Internet Explorer) as well.

There are few important points due to which we are not moving forward with the Selenium version 3.0:

1. Selenium version 3.0 is an unstable version which is not fully supported by all latest web browsers (Mozilla Firefox, Google Chrome & Internet Explorer).

2. Selenium version 3.0 doesn’t support Mozilla Firefox version 47.0.0, however, it supports other lower and higher versions. For more details, refer: https://raw.githubusercontent.com/SeleniumHQ/selenium/master/java/CHANGELOG

3. The current stable version of Selenium is 2.53, which is being used with OpKey and supports all latest web browsers (Mozilla Firefox, Google Chrome & Internet Explorer)

4. If you want to use Selenium 3.0 then you need ‘geckodriver’ but ‘geckodriver’ is not yet feature complete & fully compatible. For more details, refer: https://github.com/mozilla/geckodriver#supported-firefoxen

5. In fact, ‘geckodriver’ is in implementation (unstable) state with Mozilla Firefox (version 48 or 48+) and that is the reason behind incompatibility of Selenium 3.0 with latest Mozilla Firefox browser.

 

Currently, we are providing full support of OpKey with Selenium version 2.53 (stable version) along with all latest web browsers (Mozilla Firefox version upto 47, Google Chrome version upto 55, Internet Explorer version 8 to 11). Meanwhile, we are constantly reviewing all relevant updates and as soon as Selenium 3.0 becomes available with its stable release, we will also upgrade to the latest stable version of selenium 3 in OpKey.

Important Links:

https://github.com/mozilla/geckodriver/issues

https://raw.githubusercontent.com/SeleniumHQ/selenium/master/java/CHANGELOG

https://developer.mozilla.org/en-US/docs/Mozilla/QA/Marionette/WebDriver/status

https://github.com/mozilla/geckodriver#supported-firefoxen

 

Recent Posts

Free Trial

This site use Cookies to deliver our Service. By using this site you acknowledge that you have read and accepted Our Privacy and Cookie Policy. Your interest in OpKey or use of its free trial or purchase of a subscription package is subject to these Terms and Policies